Thursday, 18 September 2014

APS 11.1.2.3.502 diagnostic report failure

If you are running 11.1.2.3 and a Provider Services version before patch 502 then if you run a diagnostics report you should hopefully see a pass for the Essbase web services.


If you decide to apply patch 502 or later then there are some changes that have been made to the web services.

After applying 502 the diagnostics report should report two failures with the Essbase web services, one for the web application and one for the http server.


If you use the web services or are interested in why the report has suddenly started displaying failures then within the readme there is a hint under the documentation updates.

WSDL URLs for Essbase Web Services
The WSDL (Web Service Description Language) URLs for Essbase Web Services are disabled by default. Before using Web Services, enable WSDL using the Oracle Enterprise Manager user interface. See the Oracle Enterprise Manager documentation.


So it looks like there has been a change and the WSDL URLs which were previously enabled by default allowing the Essbase web services to be used  are now set to be disabled.

If you would like to enable the web services then this can be done in Enterprise Manager which is deployed by default in 11.1.2.3, start up the WebLogic admin server and go to:
http:// <server>:7001/em



Select the Provider Services WebLogic managed server and then Web Services



Select the “Oracle Infrastructure Web Services” tab, under the Web Service Name click “AdminServicePortType” Endpoint Name and then the configuration tab.


The WSDL will be set to false which was previously set to true, set the value to true.

Also set WSDL to true for the following Endpoint names “DatasourceServicePortType” and “QueryServicePortType

Once set restart the provider services web application.

If you run the diagnostic report again this time it should pass for the Essbase web services.


If you don’t intend on using the web services then it is probably not worth enabling and putting up with the failures as they are harmless.

2 comments:

Anonymous said...

Hello John,

Thanks for the Post, You always rocks!!! I have a question what are the default login credentials for em?? Same as web logic one??

Thanks,
Your Fan...

John Goodwin said...

Yes it is the same as the weblogic admin, epm_admin password