Saturday, 31 May 2014

Planning 11.1.2.3.500 and Smart View

Just a quick update from me which I was going to write when PSU 11.1.2.3.500 was released but I totally forgot, recently I have heard about this issue a couple of times so I thought I might as well post it in case it happens to anybody else.

When I first patched an environment with .500 everything looked good, well that was until I tested out a planning form in Smart View.


The colour formatting had been lost on retrievals and at first I instantly thought it was due to the patching so was going to rollback .500, the more I thought about it I came to the conclusion that it must be related to Smart View as there were no other noticeable problems with planning.


I checked the installed Smart View version which was 11.1.2.500 and read through the .500 readme and did not see any mention of the required version of Smart View.

I then searched for the latest version of Smart View and it was 11.1.2.5.200 at that time, I know it is currently at 11.1.2.5.210 which could even have changed by the time I post this.

I installed Smart View 11.1.2.5.200 and retrieved the same form again.


Issue resolved and just to be sure I rolled back to 11.1.2.5 and the issue was present again.

So the simple solution is if patching planning to 11.1.2.3.500 then make sure you are on Smart View 11.1.2.5.200+ which should be easy to implement if you have a small user community though more of a challenge if you have a large user base which deploys Smart View by package management.

8 comments:

srx said...

By the ay I've seen that Smart View 11.1.2.5.210 was released on Oracle support.

John Goodwin said...

Yes I included .210 in the post :)

Cameron Lackpour said...

John,

Were you able to input into closed periods and upper level members? It was very strange to say the least.

I wonder if there is something else happening in parallel as I had *exactly* that issue with Smart View and it was not solved by patching to SV .2xx but instead repatching the whole thing and getting the ADF patches in right.

http://camerons-blog-for-essbase-hackers.blogspot.com/2014/04/epm-11123500-patching-woes-trials-and.html

Take a look at the third screenshot -- that's the same lack of coloration. Is it Smart View, a patch, a coincidence, the phase of the moon? So frustrating.

Regards,

Cameron Lackpour

P.S. That patching issue I mentioned above has been confirmed by two other people who are probably just as bad at infrastructure as I am.
P.P.S. I should mention that I am on .210 Smart View and it has these unbelievably annoying freezes where Excel just goes away for 30 seconds or so during SV operations. I'm on an compact deployment Windows 2008 R2 install with Excel installed on the VM. I'm not the only one with this either and yeah, we all have pretty bad infrastructure skills. :)

John Goodwin said...

No I was not able to enter into upper level members.

I read your post a while back but where I have applied the .500 patch I have not hit those issues though I have not had much involvement with compact deployments.

Ronda said...

Has anyone had any issues with the patch and job schedules? We are experiencing an issue with users not being able to view the job schedules that others are the owner of...

Megan Pierce said...

Hi John, thanks a lot for this. It is very, very helpful. I'm still having the loss of format/color issue when I'm trying to maintain planning dimensions via the smartview planning administration extension. Do/Did you have this issue too?

Anonymous said...

John,Awesome find. thanks for posting this and it helped me save lot of time...Prasad

Anonymous said...

John,

We are running Planning 11.1.2.3.500 and Smart View 11.1.2.5.210 (downloaded 1/18) and we are seeing the following issues;

1. Column A Row Headers are overlapping Column B.
2. Column Headers do not appear unless you double click on them but they are there.
3. Business Rules are not running on save
4. When logging into a Shared Connection we cannot click directly into the password field but have to click into the user id field and tab into the password field.

Have you see this in the most current version?

Regards,

Tom